import re
regex = re.compile(r"^(?:[A-Z][a-z]+\.(?:jpg|png|gif),){4,}$", flags=re.MULTILINE)
test_str = ("Chrysanthemum.jpg,Desert.png,Hydrangeas.gif,Jellyfish.jpg,Koala.jpg,Lighthouse.png,\n"
"Chrysanthemum.jpg,Desert.png,Hydrangeas.gif,\n"
"Chrysanthemum.jpg,\n"
"Chrysanthemum.jpg,Desert.png,\n"
"Salvis.jpg,Sumeet.jpg,Jacob.png,Srlawr.png,")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")