package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[A-Z][a-z]+\.(?:jpg|png|gif),){4,}$`)
var str = `Chrysanthemum.jpg,Desert.png,Hydrangeas.gif,Jellyfish.jpg,Koala.jpg,Lighthouse.png,
Chrysanthemum.jpg,Desert.png,Hydrangeas.gif,
Chrysanthemum.jpg,
Chrysanthemum.jpg,Desert.png,
Salvis.jpg,Sumeet.jpg,Jacob.png,Srlawr.png,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}