re = /^(?:[A-Z][a-z]+\.(?:jpg|png|gif),){4,}$/m
str = 'Chrysanthemum.jpg,Desert.png,Hydrangeas.gif,Jellyfish.jpg,Koala.jpg,Lighthouse.png,
Chrysanthemum.jpg,Desert.png,Hydrangeas.gif,
Chrysanthemum.jpg,
Chrysanthemum.jpg,Desert.png,
Salvis.jpg,Sumeet.jpg,Jacob.png,Srlawr.png,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end