package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[\b.*?\b\.]`)
var str = `animal: [cat.], animal:[dog.]`
var substitution = "frog"
fmt.Println(re.ReplaceAllString(str, substitution))
}