const regex = new RegExp('\\[\\b.*?\\b\\.]', 'gm')
const str = `animal: [cat.], animal:[dog.]`;
const subst = `frog`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);