// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[\b.*?\b\.]").unwrap();
let string = "animal: [cat.], animal:[dog.]";
let substitution = "frog";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}