re = /\[\b.*?\b\.]/m
str = 'animal: [cat.], animal:[dog.]'
subst = 'frog'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result