import re
regex = re.compile(r"\[\b.*?\b\.]", flags=re.MULTILINE)
test_str = "animal: [cat.], animal:[dog.]"
subst = "frog"
result = regex.sub(subst, test_str)
if result:
print(result)