use strict;
my $str = 'animal: [cat.], animal:[dog.]';
my $regex = qr/\[\b.*?\b\.]/mp;
my $subst = 'frog';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";