import Foundation
let pattern = #"\[\b.*?\b\.]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"animal: [cat.], animal:[dog.]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"frog"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)