package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b[AP]M\W+(?:-\W+)?([^:\n]+):`)
var str = `4/16/14, 10:24 AM - John Doe likes your photo
4/16/14, 10:24 AM John Doe replied to your comment
4/16/14, 10:24 AM John Doe: Whats going on
4/16/14, 10:24 AM John Doe: Whats going on : hmmm`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}