re = /\b[AP]M\W+(?:-\W+)?([^:\n]+):/
str = '4/16/14, 10:24 AM - John Doe likes your photo
4/16/14, 10:24 AM John Doe replied to your comment
4/16/14, 10:24 AM John Doe: Whats going on
4/16/14, 10:24 AM John Doe: Whats going on : hmmm'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end