// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b[AP]M\W+(?:-\W+)?([^:\n]+):").unwrap();
let string = "4/16/14, 10:24 AM - John Doe likes your photo
4/16/14, 10:24 AM John Doe replied to your comment
4/16/14, 10:24 AM John Doe: Whats going on
4/16/14, 10:24 AM John Doe: Whats going on : hmmm";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}