import Foundation
let pattern = #"\b[AP]M\W+(?:-\W+)?([^:\n]+):"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
4/16/14, 10:24 AM - John Doe likes your photo
4/16/14, 10:24 AM John Doe replied to your comment
4/16/14, 10:24 AM John Doe: Whats going on
4/16/14, 10:24 AM John Doe: Whats going on : hmmm
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)