import re
regex = re.compile(r"\b[AP]M\W+(?:-\W+)?([^:\n]+):")
test_str = ("4/16/14, 10:24 AM - John Doe likes your photo\n"
"4/16/14, 10:24 AM John Doe replied to your comment\n"
"4/16/14, 10:24 AM John Doe: Whats going on\n"
"4/16/14, 10:24 AM John Doe: Whats going on : hmmm")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")