using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\b(create|alter|drop)\s+(procedure|proc|table|trigger|view|function)\b\s\[dbo\].)\[.*?\]";
string input = @"this is a test... bonjour les mecs.
coucou2
Est-ce que ça va bien par chez vous?
ben oui.
<B>ici c'est pepsi</B> test
ALTER PROCEDURE test
(
merveilleux
)
fini
CREATE PROC dbo.[test2]
encore fini...";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}