import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\b(create|alter|drop)\\s+(procedure|proc|table|trigger|view|function)\\b\\s\\[dbo\\].)\\[.*?\\]";
final String string = "this is a test... bonjour les mecs.\n"
+ "coucou2\n\n"
+ "Est-ce que ça va bien par chez vous?\n"
+ "ben oui.\n"
+ "<B>ici c'est pepsi</B> test\n"
+ "ALTER PROCEDURE test\n"
+ "(\n"
+ "merveilleux\n"
+ ")\n\n"
+ "fini\n\n"
+ "CREATE PROC dbo.[test2]\n\n"
+ "encore fini...";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}