const regex = /(?<=\b(create|alter|drop)\s+(procedure|proc|table|trigger|view|function)\b\s\[dbo\].)\[.*?\]/im;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\b(create|alter|drop)\\s+(procedure|proc|table|trigger|view|function)\\b\\s\\[dbo\\].)\\[.*?\\]', 'im')
const str = `this is a test... bonjour les mecs.
coucou2
Est-ce que ça va bien par chez vous?
ben oui.
<B>ici c'est pepsi</B> test
ALTER PROCEDURE test
(
merveilleux
)
fini
CREATE PROC dbo.[test2]
encore fini...`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}