# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\b(create|alter|drop)\s+(procedure|proc|table|trigger|view|function)\b\s\[dbo\].)\[.*?\]"
test_str = ("this is a test... bonjour les mecs.\n"
"coucou2\n\n"
"Est-ce que ça va bien par chez vous?\n"
"ben oui.\n"
"<B>ici c'est pepsi</B> test\n"
"ALTER PROCEDURE test\n"
"(\n"
"merveilleux\n"
")\n\n"
"fini\n\n"
"CREATE PROC dbo.[test2]\n\n"
"encore fini...")
matches = re.search(regex, test_str, re.IGNORECASE | re.MULTILINE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.