$re = '/(?<=\b(create|alter|drop)\s+(procedure|proc|table|trigger|view|function)\b\s\[dbo\].)\[.*?\]/im';
$str = 'this is a test... bonjour les mecs.
coucou2
Est-ce que ça va bien par chez vous?
ben oui.
<B>ici c\'est pepsi</B> test
ALTER PROCEDURE test
(
merveilleux
)
fini
CREATE PROC dbo.[test2]
encore fini...';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);