import Foundation
let pattern = #"(?<=\b(create|alter|drop)\s+(procedure|proc|table|trigger|view|function)\b\s\[dbo\].)\[.*?\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
this is a test... bonjour les mecs.
coucou2
Est-ce que ça va bien par chez vous?
ben oui.
<B>ici c'est pepsi</B> test
ALTER PROCEDURE test
(
merveilleux
)
fini
CREATE PROC dbo.[test2]
encore fini...
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}