re = /(?<=\b(create|alter|drop)\s+(procedure|proc|table|trigger|view|function)\b\s\[dbo\].)\[.*?\]/im
str = 'this is a test... bonjour les mecs.
coucou2
Est-ce que ça va bien par chez vous?
ben oui.
<B>ici c\'est pepsi</B> test
ALTER PROCEDURE test
(
merveilleux
)
fini
CREATE PROC dbo.[test2]
encore fini...'
# Print the match result
str.match(re) do |match|
puts match.to_s
end