const regex = /(.*?)Section title:/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*?)Section title:', 'gms')
const str = `this is the Section title:text for the section`;
const subst = `Section title: $1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);