import Foundation
let pattern = #"(.*?)Section title:"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"this is the Section title:text for the section"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"Section title: $1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)