re = /(.*?)Section title:/m
str = 'this is the Section title:text for the section'
subst = 'Section title: $1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result