import re
regex = re.compile(r"(.*?)Section title:", flags=re.MULTILINE | re.DOTALL)
test_str = "this is the Section title:text for the section"
subst = "Section title: $1"
result = regex.sub(subst, test_str)
if result:
print(result)