use strict;
my $str = 'this is the Section title:text for the section';
my $regex = qr/(.*?)Section title:/msp;
my $subst = 'Section title: $1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";