const regex = new RegExp('\\b(?<!-)(?=(?:[a-z\\d-]*[A-Z]){2})[A-Za-z\\d]+(?:-[A-Za-z\\d]+)*\\b(?!-)', 'gm')
const str = `ABC
AbC
ABc
A-ABC
a-ABC
ABC-a
ABC123
ABC-123
123-ABC
BC
this is a testAB
A-bc a-b-c
-AA-----
ABC, AbC, ABc, A-ABC, a-ABC, ABC-a, ABC123, ABC-123, 123-ABC.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}