import re
regex = re.compile(r"\b(?<!-)(?=(?:[a-z\d-]*[A-Z]){2})[A-Za-z\d]+(?:-[A-Za-z\d]+)*\b(?!-)", flags=re.MULTILINE)
test_str = ("ABC\n"
"AbC\n"
"ABc\n"
"A-ABC\n"
"a-ABC\n"
"ABC-a\n"
"ABC123\n"
"ABC-123\n"
"123-ABC\n"
"BC\n\n"
"this is a testAB\n\n"
"A-bc a-b-c\n\n"
"-AA-----\n\n"
"ABC, AbC, ABc, A-ABC, a-ABC, ABC-a, ABC123, ABC-123, 123-ABC.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")