#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Material Tracking\n=================\nMaterial I.D. Port # Cassette Slots \n------------- ------ -------------- \n(\S+)\s+Port (\d) : ([0-9 ]+)\n([\w\s]+):\s+(\d+)\s\n\nParameter #1"
Local $sString = "Material Tracking" & @CRLF & _
"=================" & @CRLF & _
"Material I.D. Port # Cassette Slots " & @CRLF & _
"------------- ------ -------------- " & @CRLF & _
"SNF713.1 Port 2 : 14 15 16 17 18 19 20 21 22 23 24 25 " & @CRLF & _
"DUMMY WAFERS : 16 " & @CRLF & _
"" & @CRLF & _
"Parameter #1 Avg. #1 Std.Dev. #2 Avg. #2 Std.Dev. "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")