// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Material Tracking\n=================\nMaterial I.D. Port # Cassette Slots \n------------- ------ -------------- \n(\S+)\s+Port (\d) : ([0-9 ]+)\n([\w\s]+):\s+(\d+)\s\n\nParameter #1").unwrap();
let string = "Material Tracking
=================
Material I.D. Port # Cassette Slots
------------- ------ --------------
SNF713.1 Port 2 : 14 15 16 17 18 19 20 21 22 23 24 25
DUMMY WAFERS : 16
Parameter #1 Avg. #1 Std.Dev. #2 Avg. #2 Std.Dev. ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}