re = /Material Tracking\n=================\nMaterial I.D. Port # Cassette Slots \n------------- ------ -------------- \n(\S+)\s+Port (\d) : ([0-9 ]+)\n([\w\s]+):\s+(\d+)\s\n\nParameter #1/m
str = 'Material Tracking
=================
Material I.D. Port # Cassette Slots
------------- ------ --------------
SNF713.1 Port 2 : 14 15 16 17 18 19 20 21 22 23 24 25
DUMMY WAFERS : 16
Parameter #1 Avg. #1 Std.Dev. #2 Avg. #2 Std.Dev. '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end