const regex = /Material Tracking\n=================\nMaterial I.D. Port # Cassette Slots \n------------- ------ -------------- \n(\S+)\s+Port (\d) : ([0-9 ]+)\n([\w\s]+):\s+(\d+)\s\n\nParameter #1/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Material Tracking\\n=================\\nMaterial I.D. Port # Cassette Slots \\n------------- ------ -------------- \\n(\\S+)\\s+Port (\\d) : ([0-9 ]+)\\n([\\w\\s]+):\\s+(\\d+)\\s\\n\\nParameter #1', 'gm')
const str = `Material Tracking
=================
Material I.D. Port # Cassette Slots
------------- ------ --------------
SNF713.1 Port 2 : 14 15 16 17 18 19 20 21 22 23 24 25
DUMMY WAFERS : 16
Parameter #1 Avg. #1 Std.Dev. #2 Avg. #2 Std.Dev. `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}