#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^spotify\/streams\/\d{8}\/[A-Z]{2}_streams_\d{8}\.csv"
Local $sString = "spotify/streams/20200819/NL_streams_20200819.csv" & @CRLF & _
"spotify/streams/20200819/nl_streams_20200819.csv" & @CRLF & _
"test/spotify/tracks" & @CRLF & _
"spotify/tracks/hello.world"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")