use strict;
my $str = 'spotify/streams/20200819/NL_streams_20200819.csv
spotify/streams/20200819/nl_streams_20200819.csv
test/spotify/tracks
spotify/tracks/hello.world';
my $regex = qr/^spotify\/streams\/\d{8}\/[A-Z]{2}_streams_\d{8}\.csv/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}