// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^spotify\/streams\/\d{8}\/[A-Z]{2}_streams_\d{8}\.csv").unwrap();
let string = "spotify/streams/20200819/NL_streams_20200819.csv
spotify/streams/20200819/nl_streams_20200819.csv
test/spotify/tracks
spotify/tracks/hello.world";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}