using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^spotify\/streams\/\d{8}\/[A-Z]{2}_streams_\d{8}\.csv";
string input = @"spotify/streams/20200819/NL_streams_20200819.csv
spotify/streams/20200819/nl_streams_20200819.csv
test/spotify/tracks
spotify/tracks/hello.world";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}