const regex = /id \[([\d\w-]*)\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('id \\[([\\d\\w-]*)\\]', 'gm')
const str = `Error: GraphQL error: Fetch failure: HTTP 500 'Internal Server Error' for
https://localhost:3000: Unhandled command [https://localhost:3000.AddTag]
in [https://localhost:3000.AccountEntity]
with id [7f4cd122-4f1e-53bb-8501-68fc525bb1cd]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}