// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)id \[([\d\w-]*)\]").unwrap();
let string = "Error: GraphQL error: Fetch failure: HTTP 500 'Internal Server Error' for
https://localhost:3000: Unhandled command [https://localhost:3000.AddTag]
in [https://localhost:3000.AccountEntity]
with id [7f4cd122-4f1e-53bb-8501-68fc525bb1cd]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}