#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "function(\s*)\(((\S+,* *)*)\)(\s*){"
Local $sString = "function (param1, param2){" & @CRLF & _
" //" & @CRLF & _
"}" & @CRLF & _
"function (){" & @CRLF & _
" //" & @CRLF & _
"}" & @CRLF & _
"function() {" & @CRLF & _
" //" & @CRLF & _
"}" & @CRLF & _
"function (param1, param2){" & @CRLF & _
" //" & @CRLF & _
"}"
Local $sSubst = "($2) => {"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)