const regex = /function(\s*)\(((\S+,* *)*)\)(\s*){/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('function(\\s*)\\(((\\S+,* *)*)\\)(\\s*){', 'g')
const str = `function (param1, param2){
//
}
function (){
//
}
function() {
//
}
function (param1, param2){
//
}`;
const subst = `($2) => {`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);