use strict;
my $str = 'function (param1, param2){
//
}
function (){
//
}
function() {
//
}
function (param1, param2){
//
}';
my $regex = qr/function(\s*)\(((\S+,* *)*)\)(\s*){/p;
my $subst = '($2) => {';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";