use strict;
my $str = '...TABLE __? (`id` int(11....';
my $regex = qr/__\?/p;
my $subst = 'list_';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";