$re = '/__\?/';
$str = '...TABLE __? (`id` int(11....';
$subst = "list_";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;