const regex = /\([^(]*ppm\b[^)]*\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\([^(]*ppm\\b[^)]*\\)', 'g')
const str = `abc(cow) and def(pig 0.2ppmsheep)
abc(cow) and def(pig 0.2ppm sheep)
Menthol(0.3ppm) Michale(36 years old man)
Michale(36 years old man) Menthol(0.3ppm)
Good(5%, 5,500ppm)
abcd(333ppm) abcd(333ppm, 30%)
abcd1234(abc 333ppm)
abcd(333ppm, 30%) abcd(333ppm)
abc(cow) and def(pig 0.2ppm sheep)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}