import re
regex = re.compile(r"\([^(]*ppm\b[^)]*\)")
test_str = ("abc(cow) and def(pig 0.2ppmsheep)\n"
"abc(cow) and def(pig 0.2ppm sheep)\n\n"
"Menthol(0.3ppm) Michale(36 years old man)\n"
"Michale(36 years old man) Menthol(0.3ppm)\n"
"Good(5%, 5,500ppm)\n\n"
"abcd(333ppm) abcd(333ppm, 30%)\n"
"abcd1234(abc 333ppm)\n"
"abcd(333ppm, 30%) abcd(333ppm)\n\n"
"abc(cow) and def(pig 0.2ppm sheep)\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")