import Foundation
let pattern = #"\([^(]*ppm\b[^)]*\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
abc(cow) and def(pig 0.2ppmsheep)
abc(cow) and def(pig 0.2ppm sheep)
Menthol(0.3ppm) Michale(36 years old man)
Michale(36 years old man) Menthol(0.3ppm)
Good(5%, 5,500ppm)
abcd(333ppm) abcd(333ppm, 30%)
abcd1234(abc 333ppm)
abcd(333ppm, 30%) abcd(333ppm)
abc(cow) and def(pig 0.2ppm sheep)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)