// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\([^(]*ppm\b[^)]*\)").unwrap();
let string = "abc(cow) and def(pig 0.2ppmsheep)
abc(cow) and def(pig 0.2ppm sheep)
Menthol(0.3ppm) Michale(36 years old man)
Michale(36 years old man) Menthol(0.3ppm)
Good(5%, 5,500ppm)
abcd(333ppm) abcd(333ppm, 30%)
abcd1234(abc 333ppm)
abcd(333ppm, 30%) abcd(333ppm)
abc(cow) and def(pig 0.2ppm sheep)
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}