#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(Yii::t\(\s*)(\'|\")(.*?)(\'|\")\,\s*(\'|\")(.*?)(\'|\")\)"
Local $sString = "Yii::t('backend','My Profile')" & @CRLF & _
"Yii::t('backend','Log Out')" & @CRLF & _
"does not match these:" & @CRLF & _
"" & @CRLF & _
"Yii::t("backend", "Search...")" & @CRLF & _
"Yii::t("backend", 'Sounds')" & @CRLF & _
"but matches these:" & @CRLF & _
"Yii::t("backend","Search...")" & @CRLF & _
"Yii::t("backend",'Sounds')" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")