use strict;
my $str = 'Yii::t(\'backend\',\'My Profile\')
Yii::t(\'backend\',\'Log Out\')
does not match these:
Yii::t("backend", "Search...")
Yii::t("backend", \'Sounds\')
but matches these:
Yii::t("backend","Search...")
Yii::t("backend",\'Sounds\')
';
my $regex = qr`(Yii::t\(\s*)(\'|\")(.*?)(\'|\")\,\s*(\'|\")(.*?)(\'|\")\)`p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}